summaryrefslogtreecommitdiff
AgeCommit message (Expand)Author
2020-03-24conf: some comment clarification, get rid of removed plugin; cmd: fix variabl...HEADmasterVon Random
2019-10-28batt: add default title; load: change default titleVon Random
2019-10-28plugins: allow disabling of title field; pacman: rename to cmd; cmd: use firs...Von Random
2019-07-08plugins: improve readability, move to str().format() in many placesVon Random
2019-07-05plugins, vdstatus: massive plugin overhaul, conf: some formattingVon Random
2019-06-17vdstatus: replace deprecated yaml.load() with yaml.safe_load() callVon Random
2019-06-17gitignore: ignore plugins/custom*.py, because some stuff has to be hard codedVon Random
2019-05-24filecat plugin: a simple plugin to read file contentsVon Random
2019-03-28vdstatus, plugins: some refactoring and better usage of dict() methods; renam...Von Random
2019-03-21pacman plugin: not so much pacman anymore, but line counter; still defaults t...Von Random
2019-03-11load plugin: get rid of list comprehension altogetherVon Random
2019-03-11vdstatus: proper utf-8 output in jsonVon Random
2019-03-11mem plugin: update formatting as wellVon Random
2019-03-11load plugin: formatting update, less frequent queriesVon Random
2019-03-06completely remove global hide_ok to avoid ambiguityVon Random
2019-03-06add dependencies to the readmeVon Random
2019-03-06remove todo for fga, add support for hide_ok in memVon Random
2019-03-05some cleanupVon Random
2019-03-05some more sensible defaults, get rid of todoVon Random
2019-03-05move config to yaml, json is atrociousVon Random
2019-02-28fix pacman plugin to properly parse command outputVon Random
2019-01-31fix and simplify pacman.pyVon Random
2019-01-16replace an ugly hack with a proper subprocess.Popen() in the pacman pluginVon Random
2018-11-09reverse retry conditionVon Random
2018-11-09retry for fga pluginVon Random
2018-11-02fucking-great-advice addedVon Random
2018-05-24there is no need to explicitly pass sys.argv to argparse... embarrassingVon Random
2018-04-28a bit of refactoring, now batt and pacman plugins have more optionsVon Random
2017-12-16use json instead of ini: less readable, easier to work withVon Random
2017-11-30add pytz to the mix, so that we can display time for specific time zones (tot...Von Random
2017-01-13a quick and very ugly fix for pacman -QuVon Random
2017-01-13add hide_ok option support both globally (precedence) and per plugin, true by...Von Random
2017-01-13use a proper tool to check for updatesVon Random
2017-01-13update notification should be urgentVon Random
2017-01-12remove unused modulesVon Random
2017-01-12add pacman plugin to monitor the number of available updatesVon Random
2016-11-28move plugins.common only class into plugins moduleVon Random
2016-11-21get rid of thread_id and useless logic it usedVon Random
2016-11-19yay, found out about Thread.daemon lol, also more oop and less code duplicationVon Random
2016-11-18a bit more OOPVon Random
2016-11-18some primitive exit handling, still have to do something about waiting till t...Von Random
2016-11-03hiding load average in ok status is now optionalVon Random
2016-10-31enable unbuffered print instead of using shebangVon Random
2016-10-31fix battery status staying urgent after being chargedVon Random
2016-10-31load average as wellVon Random
2016-10-31disk check to auto hide as wellVon Random
2016-10-25replace colors with urgency status + add means to hide unimportant measures; ...Von Random
2016-10-23oops, fix one symbol missingVon Random
2016-10-23style fix + TODO listVon Random
2016-10-23fix config.get -> config.getintVon Random